Magic Link Issue
Incident Report for Crowdcast
Resolved
This incident has been resolved.
Posted Feb 09, 2022 - 09:41 PST
Investigating
We're currently experiencing an issue that is preventing some people from accessing Crowdcast via a "magic link" or the link that is included in event confirmation emails and sign in/login link emails. Our engineering team is working actively to get things back to normal. We will update this page when we have more information.
Posted Feb 09, 2022 - 09:33 PST