Resolved
All systems remain stable. We have identified the root cause of the cascading issues that occurred under high load and are deploying an update today to prevent this from happening again. Thank you for your continued patience.
Monitoring
We've scaled our systems to handle significantly higher loads from multiple simultaneous large-scale events. Our systems are currently stable, and we continue to monitor them closely.
Investigating
The team is actively investigating an issue affecting our service. We'll update you as soon as we can.