Impact: Some real-time updates were delayed for a portion of users. No data was lost.
Timeline: Started at 7pm, peaked at 7:10pm, and resolved by 9:30pm ET.
Cause: A sudden traffic spike from a high-scale event pushed past our autoscaling limits.
What we did: Added capacity and tuned autoscaling.
Now: Everything is stable and performing normally.
What’s next: Stronger scaling safeguards, smarter rate limiting, and improved monitoring.
Resolved
Impact: Some real-time updates were delayed for a portion of users. No data was lost.
Timeline: Started at 7pm, peaked at 7:10pm, and resolved by 9:30pm ET.
Cause: A sudden traffic spike from a high-scale event pushed past our autoscaling limits.
What we did: Added capacity and tuned autoscaling.
Now: Everything is stable and performing normally.
What’s next: Stronger scaling safeguards, smarter rate limiting, and improved monitoring.
Monitoring
Services are coming back online, and we’re monitoring performance.
Identified
We’re hitting scale limits on our real-time chat and interaction services due to a large event. We’re increasing capacity now and will restore full service as quickly as possible.
Investigating
The team is actively investigating an issue affecting our service. We'll update you as soon as we can.